when install jupyter notebook with python3 Error: NotImplementedError

This problem is related to the tornado server which jupyter notebook uses. To fix this problem, we need to edit the file tornado/platform/asyncio.py, This file is under your virtualenv directory, I have an env3 virtual environment, so my tornado file is C:\Users\Developer\Envs\env3\Lib\site-packages\tornado\platform\asyncio.py, by adding: After all the main imports.

How to get datetime from date() using JavaScript

getDateTime = () => {    var today = new Date();    var date =      today.getFullYear() +      “-” +      (“0” + (today.getMonth() + 1)).slice(-2) +      “-” +      (“0” + today.getDate()).slice(-2);    var time =      (“0” + today.getHours()).slice(-2) +      “:” +      (“0” + today.getMinutes()).slice(-2) +      “:” +      (“0″ + today.getSeconds()).slice(-2);    var dateTime = date + ” ” + time;    return dateTime;  };

How to launch Android Emulator using command line

Cd to the directory of the emulator which contains the “emulator.exe”; run emulator -list-avds to list all the available avds’ name; run emulator -avds [avd-name] to run the specific avd.

Using Firebase to host multi website

Initiate your project cd into your working directory, using firebaes init to initiate your website. Then three files will appear under your folder, “.firebaserc”, “.gitignore” and “firebase.json”. Change your setting In “firebase.json” file, it contains your hosting settings. a configuration example below: { “hosting”: { “site”: “XXXXXXX”, // the site name in your Firebase console…

install mysqlclient on win10 python37

from: https://stackoverflow.com/questions/51146117/installing-mysqlclient-in-python-3-6-in-windows I am using python3.7 on Windows 10 operating system. I had same issue and after a long research I had installed it successfully. Install “Microsoft Visual C++ Build Tools” AND My OS is having 64 bit operating system but still then it need to install 32 bit version “mysqlclient‑1.4.2‑cp37‑cp37m‑win32.whl” Download binary wheels from…

flutter-error Unable to locate a development device; please run ‘flutter doctor’ for information about installing additional components

from: https://github.com/flutter/flutter/issues/19805 when you encounter this error, it means that flutter cannot find the SDK in your system. You can install the android sdk manually on your operation system. First, download SDK here: https://developer.android.com/studio skd-tools-windows-334XXXX.zip unzip it into one directory Second, find the \tools\bin file and open cmd shell here. run “.\sdkmanager.bat “platforms;android-28” “platform-tools” “build-tools:28.0.3”…